summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..600fd0ac689b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=go-check
+pkgver=1
+pkgrel=2
+pkgdesc="Rich testing framework"
+arch=('x86_64' 'i686')
+url="http://launchpad.net/gocheck"
+license=('BSD')
+makedepends=('go' 'bzr')
+options=('!strip' '!emptydirs')
+_gourl=launchpad.net/gocheck
+
+build() {
+ cd "$srcdir"
+ GOPATH="$srcdir" go get -v -x ${_gourl}/...
+}
+
+check() {
+ GOPATH="$srcdir" go test -v -x ${_gourl}/...
+}
+
+package() {
+ source /etc/profile.d/go.sh
+ mkdir -p "${pkgdir}/$GOPATH"
+ cp -Rv --preserve=timestamps ${srcdir}/{src,pkg} "${pkgdir}/$GOPATH"
+}
+
+# vim:set ts=2 sw=2 et: