summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 18 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33aad0c07273..27cfaeb61250 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: Forest Crossman <cyrozap at gmail dot com>
+# Thanks: Forest Crossman <cyrozap at gmail dot com>
+# Maintainer: Stephanie Wilde-Hobbs <gpg@stephanie.is>
-pkgname=greenpak-designer
-_pkgver=6.25
-_pkgrel=3
-pkgver=$_pkgver.$(printf "%03d" $_pkgrel)
+pkgname=go-configure-sw-hub
+_pkgver_major=6.32
+_pkgver_minor=002
+pkgver=$_pkgver_major.$_pkgver_minor
pkgrel=1
-pkgdesc="GreenPAK3-6 Designer"
-arch=('i686' 'x86_64')
-url="https://www.dialog-semiconductor.com/greenpak-designer-software"
+pkgdesc="Renesas/Dialog/Silego Go Configure software hub (greenpak designer)"
+arch=('x86_64')
+url="https://www.renesas.com/us/en/software-tool/go-configure-software-hub"
license=('custom')
makedepends=('patchelf')
-depends=('desktop-file-utils' 'graphviz' 'gtk-update-icon-cache' 'libusb' 'qt5-svg' 'qt5-webview' 'qwt' 'shared-mime-info')
-conflicts=('greenpak-designer-dev')
-replaces=('greenpak-designer-dev')
+depends=('desktop-file-utils' 'graphviz' 'gtk-update-icon-cache' 'libusb' 'qt5-svg' 'qt5-webview' 'qt5-serialport' 'qwt' 'shared-mime-info')
+conflicts=('greenpak-designer-dev' 'greenpak-designer')
+replaces=('greenpak-designer-dev' 'greenpak-designer')
options=('!strip')
-install=${pkgname}.install
-source_i686=("https://support.dialog-semiconductor.com/downloads/GP_Designer_v${pkgver}_Debian-testing_i386_Setup.deb")
-sha256sums_i686=('34bea41fdd706d4a7ed34ee18769ff0fa299c0950f2d477a11fa06109671f349')
-source_x86_64=("https://support.dialog-semiconductor.com/downloads/GP_Designer_v${pkgver}_Debian-testing_amd64_Setup.deb")
-sha256sums_x86_64=('93f6ba4899bf9efe7e3316eb497763a52db1cfa93ef2806c6d83536db9a39095')
+source=("https://renesasweb-greenpak.s3.us-west-2.amazonaws.com/v${_pkgver_major}/go-configure-sw-hub-v${pkgver}-debian-testing-amd64-external.deb")
+sha256sums=('2787e52ff890c18fac125854ca59ea025464926bbf15d6938e64b0870376deaa')
package() {
# Extract the package data
@@ -32,14 +30,14 @@ package() {
# Remove unneeded binaries and files
rm -r "${pkgdir}"/usr/bin
- rm -r "${pkgdir}/usr/local/${pkgname}/bin"/{platforms,QtWebEngineProcess,slgspicebackend,qt.conf}
+ rm -r "${pkgdir}/usr/local/${pkgname}/bin"/{platforms,QtWebEngineProcess,qt.conf}
# Move binaries to /usr/bin
mv "${pkgdir}/usr/local/${pkgname}/bin" "${pkgdir}"/usr/bin
ln -s "../lib/${pkgname}/slgspicebackend" "${pkgdir}"/usr/bin/slgspicebackend
# Remove unneeded libraries
- rm -r "${pkgdir}/usr/local/${pkgname}/lib"/{libQt5*,libqwt*,libusb-1.0.so*}
+ rm -r "${pkgdir}/usr/local/${pkgname}/lib"/{libQt5*,libusb-1.0.so*}
# Move libraries to subdirectory in /usr/lib
install -dm 755 "${pkgdir}/usr/lib/${pkgname}"
@@ -55,6 +53,7 @@ package() {
# Redefine library search paths
for _exec in "${pkgdir}/usr/bin"/*; do
+ [[ -d $_exec ]] && continue
patchelf --set-rpath "\$ORIGIN/../lib/${pkgname}:\$ORIGIN/../lib" $_exec
done
for _lib in "${pkgdir}/usr/lib/${pkgname}"/{lib*,slgspicebackend}; do
@@ -63,7 +62,7 @@ package() {
# Fix desktop launchers
for _launcher in "${pkgdir}/usr/share/applications"/*.desktop; do
- sed -i "s!local/greenpak-designer/!!g" $_launcher
+ sed -i "s!local/${pkgname}/!!g" $_launcher
done
# Install license file