summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0dea4b1ccae..e9c9ad282547 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@
pkgname=go-git
epoch=1
-pkgver=2020.8.7
+pkgver=go1.15beta1.r138.gba9e1088997
pkgrel=1
pkgrepo=go
pkgdesc='Core compiler tools for the Go programming language'
@@ -22,6 +22,8 @@ arch=(i686 x86_64)
url='http://golang.org/'
license=(BSD)
makedepends=(git go)
+provides=(go)
+conficts=(go)
options=(!strip staticlibs)
source=(git+https://go.googlesource.com/go#branch=master)
md5sums=('SKIP')
@@ -34,6 +36,11 @@ esac
export GOROOT_FINAL=/usr/lib/go
export GOROOT_BOOTSTRAP=/usr/lib/go
+pkgver() {
+ cd go
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
export GOROOT="$srcdir/$pkgrepo"
export GOBIN="$GOROOT/bin"