summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4acaa491cb3b..9c3d7d80b6b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=go-nebulas-git
pkgver=r2209.78433128
-pkgrel=2
+pkgrel=3
pkgdesc="Official Go implementation of the Nebulas protocol"
arch=("x86_64")
url="https://github.com/nebulasio/go-nebulas"
@@ -20,10 +20,10 @@ source=("$pkgname::git+https://github.com/nebulasio/go-nebulas.git"
"go-nebulas-git.install"
"go-nebulas-git.conf")
sha256sums=('SKIP'
- '47fb517be710ac459c446f34d69728f3416ae51aeccb9045ecdf8443450433ff'
+ 'a6cfe7b259320720830c190adf93329c80f85ef62019ca4fdb544cbb0fe6dbc5'
'f02573abd8979f50f4541b8e2c4b732f8ced823dc105b368d59b09e2591b3071'
- '3e11da7d6ef33e69de2f65c8d77f41d0e937f6900fe064572170648e92350892'
- '3b79cfec7c854ad35279c308068a56f499dee83db492b4ce7de3c1fb68890571'
+ 'c950199571a367dff0987e9dac583199290df67565922386ff717d93b40a5183'
+ '25c7cef2f26594514a5616bcc3965484dcd8dd7972f3e3e55087ec302aa6bebd'
'eba28579d2c1d1213ed5dc09f84d8244de20bca1828d9adfaac841b603b54f06')
pkgver() {
@@ -53,16 +53,22 @@ package() {
install -Dm644 ${pkgname}.conf ${pkgdir}/etc/ld.so.conf.d/${pkgname}.conf
install -dm755 ${pkgdir}/usr/lib/${pkgname}
install -Dm755 ${_dir}/nf/nvm/native-lib/*.so ${pkgdir}/usr/lib/${pkgname}
+ install -dm755 ${pkgdir}/opt/${pkgname}/lib
+ cp -r ${_dir}/nf/nvm/v8/lib/1.0.0 ${pkgdir}/opt/${pkgname}/lib
+ cp -r ${_dir}/nf/nvm/v8/lib/1.0.5 ${pkgdir}/opt/${pkgname}/lib
# Install Binary
- install -Dm755 ${_dir}/neb ${pkgdir}/usr/bin/neb
- install -Dm755 ${_dir}/neb-crashreporter ${pkgdir}/usr/bin/neb-crashreporter
+ install -Dm755 ${_dir}/neb ${pkgdir}/opt/${pkgname}/neb
+ install -Dm755 ${_dir}/neb-crashreporter ${pkgdir}/opt/${pkgname}/neb-crashreporter
+ install -dm755 ${pkgdir}/usr/bin
+ ln -s ${pkgdir}/opt/${pkgname}/neb ${pkgdir}/usr/bin/neb
+ ln -s ${pkgdir}/opt/${pkgname}/neb-crashreporter ${pkgdir}/usr/bin/neb-crashreporter
# Install License
install -Dm755 ${_dir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
# Add example configuration file
- install -d ${pkgdir}/etc/go-nebulas
- install -Dm644 config.conf ${pkgdir}/etc/go-nebulas/config.conf.example
- install -Dm644 genesis.conf ${pkgdir}/etc/go-nebulas/genesis.conf.example
- cp -r ${_dir}/keydir ${pkgdir}/etc/go-nebulas/keydir.example
+ install -d ${pkgdir}/opt/${pkgname}/conf
+ install -Dm644 config.conf ${pkgdir}/opt/${pkgname}/conf/config.conf.example
+ install -Dm644 genesis.conf ${pkgdir}/opt/${pkgname}/conf/genesis.conf.example
+ cp -r ${_dir}/keydir ${pkgdir}/opt/${pkgname}/conf/keydir.example
install -Dm644 go-nebulas.service ${pkgdir}/usr/lib/systemd/system/go-nebulas.service
}