summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 968afa7e40e6..9d32517c7a3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
-# Maintainer: Vyacheslav Konovalov <vyachkonovalov@protonmail.com>
+# Maintainer: Vyacheslav Konovalov <🦀vk@protonmail.com>
pkgname=go-sendxmpp-git
-pkgver=r86.cbac6db
+pkgver=0.10.0.r12.g95a2f67
pkgrel=1
-pkgdesc='A little tool to send messages to an XMPP contact or MUC'
+pkgdesc='A tool to send messages or files to an XMPP contact or MUC'
url='https://salsa.debian.org/mdosch/go-sendxmpp'
makedepends=('git' 'go')
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
license=('BSD-2-clause')
source=('git+https://salsa.debian.org/mdosch-guest/go-sendxmpp.git')
sha256sums=('SKIP')
pkgver() {
- cd go-sendxmpp
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd go-sendxmpp
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd go-sendxmpp
- go build
+ cd go-sendxmpp
+ go build
}
package() {
- cd go-sendxmpp
+ cd go-sendxmpp
- for i in 1 5; do
- install -Dm644 man/go-sendxmpp.$i -t "${pkgdir}/usr/share/man/man$i"
- done
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/go-sendxmpp"
- install -Dm755 go-sendxmpp -t "$pkgdir/usr/bin"
+ for i in 1 5; do
+ install -Dm644 man/go-sendxmpp.$i -t "$pkgdir/usr/share/man/man$i"
+ done
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm755 go-sendxmpp -t "$pkgdir/usr/bin"
}