summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD81
1 files changed, 47 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f74658e790b..a2c3064cec92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,63 +3,76 @@
#
pkgname=go4
_Pkgname=Go4
-pkgver=6.0.0
+pkgver=6.3.0
pkgrel=1
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('x86_64')
-depends=('root' 'qt5-base')
+makedepends=('cmake')
+depends=('root' 'qt6-webengine' 'hdf5' 'cern-vdt')
+conflicts=('mbseventapi')
url="https://www.gsi.de/en/work/research/experiment_electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
-source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz"
- "Makefile.config.patch")
-sha256sums=('28e3ecccbbde5a9168e85d6b6b5abaa147c0d65ea70332cdaaa80050ad61c55f'
- 'd03fd394378e4ee97d2d17071010df046f1e9346d7b57585a694410a25bc5883')
+source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
+sha256sums=('93cf8fe4ddcb9e2e494ebe8c8cf1df2ddf25cbc1bc64f3cc7dc09348c26e3841')
prepare() {
unset GO4SYS
- cd go4-${pkgver}
-
- # make it installation friendly
- sed -i 's#\$(GO4EXEPATH)#$(DESTDIR)/&#g' Makefile
- sed -i 's#\$(GO4INCPATH)#$(DESTDIR)/&#g' Makefile
- sed -i 's#\$(GO4LIBPATH)#$(DESTDIR)/&#g' Makefile
- sed -i 's#\$(GO4TOPPATH)#$(DESTDIR)/&#g' Makefile
-
- # something change and the libraries are not found now at compilation time
- patch -Np2 < ${srcdir}/Makefile.config.patch
+ #
+ # Most files created at the end of CMakeLists.txt end up in weird locations.
+ # for now it works... this will be fixed in a new release
+ #
+ # # ================== Copy files, create old support files ==========
+ #
+ # /usr/Go4License.txt --> /usr/share/licenses/go4/Go4License.txt
+ # /usr/README.txt --> /usr/share/doc/{pkg}
+ # /usr/CHANGES.txt --> /usr/share/doc/{pkg}
+ #
+ # /usr/go4login --> /usr/bin/go4login
+ #
+ #
+ # /usr/etc/ --> /etc/{pkg}
+ # /usr/docs/ --> /usr/share/doc/{pkg}
+ # /usr/icons --> /usr/share/{pkg}/icons
+ # /usr/html --> /usr/share/doc/{pkg}/html
+ # /usr/macros --> /usr/share/{pkg}/macros
+ # /usr/python --> /usr/share/{pkg}/python
+ #
}
build() {
- cd go4-${pkgver}
- make clean-bin
- make clean
+# took from /etc/makepkg.conf but -Werror=format-security removed
+
+CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat \
+ -fstack-clash-protection -fcf-protection"
+CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
- make prefix=/usr \
- withqt=5 \
- GO4_OS=Linux \
- rpath=true \
- withdabc=yes \
- debug=1 \
- nodepend=1 \
- all || return 1
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- ## options not explored
- # noweb=1
- # nox11=1
+ ROOTSYS=/usr/lib/cmake/ROOT \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGO4_PLATFORM=Linux \
+ -DGO4_QTVERSION=Qt6 \
+ -Ddabc=ON \
+ -Dhdf5=ON \
+ -Droot7=ON \
+ -Dqt6web=ON \
+ ../go4-${pkgver}
- # options known not to work Nov/22/2019
- # designer=1
+ make
}
package() {
#install the package
- cd go4-${pkgver}
+ cd ${srcdir}/build
make DESTDIR="${pkgdir}" install
#install the license
@@ -83,7 +96,7 @@ package() {
cat <<- EOF > ${srcdir}/go4.sh
# source go4login script
- source /usr/bin/go4login
+ source /usr/go4login
# If ROOT_INCLUDE_PATH already exists, then add Go4 to it, otherwise do nothing
export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:+\$ROOT_INCLUDE_PATH:/usr/include/go4}