summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c98326904249..6d6dea898172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
#
# Note to self. It is necessary to remove the current Go4 installation -if any- otherwise the compilation fails.
# Also, after removal, use a fresh terminal as go4login variables are no longer valid
+# Maybe just unsetting GO4SYS is enough(?)
#
# It looks that ROOT6 requires the modification/definition of the variable ROOT_INCLUDE_PATH to /usr/include/go4
#
@@ -21,6 +22,8 @@ _USEQT=4 # qt4 - Qt 4.6.x and higher (recommended) <-- from the source code 5.1.
prepare() {
+ unset GO4SYS
+
cd go4-${pkgver}
# make it installation friendly
@@ -77,10 +80,10 @@ package() {
source /usr/bin/go4login
# If ROOT_INCLUDE_PATH already exists, then add Go4 to it, otherwise do nothing
- export ROOT_INCLUDE_PATH=${ROOT_INCLUDE_PATH:+$ROOT_INCLUDE_PATH:/usr/include/go4}
+ export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:+\$ROOT_INCLUDE_PATH:/usr/include/go4}
# if ROOT_INCLUDE_PATH does not exist, define it as the one from Go4, otherwise do nothing
- export ROOT_INCLUDE_PATH=${ROOT_INCLUDE_PATH:-/usr/include/go4}
+ export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:-/usr/include/go4}
EOF