summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 21 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 500bb9204a6a..4b03c54cb5d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Michael Straube <straubem@gmx.de>
# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
-pkgname=gods
+pkgbase=gods
+pkgname=('gods' 'gods-extra-music')
pkgver=0.9
pkgrel=1
pkgdesc='Gods Deluxe, remake of the platform game Gods by Bitmap Brothers'
@@ -10,22 +11,29 @@ url='http://jotd.pagesperso-orange.fr/gods/'
license=('custom')
depends=('java-runtime')
makedepends=('setconf')
-optdepends=('gods-extra-music: mp3 music pack')
source=("https://jotd.pagesperso-orange.fr/gods/GodsDeluxe-${pkgver/./_}.zip"
+ "http://jotd.free.fr/gods/Gods_extra_music.zip"
"gods.png::http://www.androidfreeware.net/software_images/gods.thumb.png"
"gods.desktop")
sha256sums=('38fe593a9ed361c65e4a4c36dd4940cde8c847849f1d5e9f15eb940089428a9c'
+ '0b92f6e8a056362af481343df2e31eb001b55e43065556e6f4c625b8933c9ca7'
'd40a00737cfcc82bb4b24110ac5d162da5dddf6041a5d83b94a2c0104ac3a2e3'
'176170bb9642eaf3c37d9d393f122334ae5080c9f9a4b69eea27d49855aa41e0')
+noextract=('Gods_extra_music.zip')
prepare() {
find Gods -type f -iname "*.bat" -delete
find Gods -type f -iname "*.dll" -delete
setconf Gods/gods.sh GODS_ROOT_DIR "/usr/share/gods"
chmod +x Gods/scripts/gods_loader.sh
+
+ mkdir Music
+ bsdtar -xf Gods_extra_music.zip -C Music
}
-package() {
+package_gods() {
+ optdepends=('gods-extra-music: mp3 music pack')
+
install -d "$pkgdir/usr/share"
cp -r Gods "$pkgdir/usr/share/gods"
install -Dm755 Gods/gods.sh "$pkgdir/usr/bin/gods"
@@ -34,3 +42,13 @@ package() {
install -Dm644 gods.desktop "$pkgdir/usr/share/applications/gods.desktop"
install -Dm644 gods.png "$pkgdir/usr/share/pixmaps/gods.png"
}
+
+package_gods-extra-music() {
+ pkgdesc='Gods Deluxe, mp3 music pack'
+ depends=('gods')
+
+ install -d "$pkgdir"/usr/share/{gods,licenses/$pkgname}
+ cp -r Music/Gods/music "$pkgdir/usr/share/gods"
+ ln -s /usr/share/licenses/gods/readme.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/readme.txt"
+}