summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebd4a5256dff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: gls <ghostlovescorebg at gmail dot com>
+
+pkgname=goenv-git
+pkgver=r1724.0cbe222
+pkgrel=1
+pkgdesc="Like pyenv and rbenv, but for Go."
+arch=('i686' 'x86_64')
+url="https://github.com/syndbg/goenv"
+license=('MIT')
+source=("git://github.com/syndbg/goenv.git")
+options=('!libtool' 'docs' 'strip')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%%-git}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname%%-git}"
+
+ for file in $(ls -1 libexec/); do
+ install -D -m755 libexec/${file} "${pkgdir}/usr/lib/goenv/libexec/${file}"
+ done
+
+}