summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7e023e2213c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+# Place the gog installation file in the same folder as this PKGBUILD
+pkgname=gog-darkest-dungeon-the-crimson-court
+_dlcparent=darkest_dungeon
+_pkgname=darkest_dungeon_the_crimson_court
+pkgver=24839
+_pkgver=24839
+_build=28859
+pkgrel=1
+pkgdesc="DLC for the ${_dlcparent} game."
+arch=('x86_64')
+url="https://www.gog.com/game/${_pkgname}"
+license=('custom')
+depends=($(echo gog-${_dlcparent} | sed 's/_/-/g'))
+makedepends=('p7zip')
+source=("${_pkgname}_${_pkgver}_${_build}.sh::gog://${_pkgname}_${_pkgver}_${_build}.sh")
+# don't download anything via makepkg
+DLAGENTS+=("gog::/usr/bin/perl -E print\(\"${RED}\"\ .\ substr\(\"%u\",\ 6\)\ .\ \"\ not\ found.\ \ Check\ the\ PKGBUILD\ for\ further\ information.${ALL_OFF}\\\\n\"\)\;\ exit\ 1")
+sha256sums=('3edb41b306b008099c7b42fb2d9feedfcbf0f0297372831df1143edf3393f5ea')
+noextract=("${_pkgname}_${_pkgver}_${_build}.sh")
+
+prepare() {
+ 7z x -tzip -y ${_pkgname}_${_pkgver}_${_build}.sh
+}
+
+package() {
+ # install DLC.
+ find "${srcdir}/data/noarch/game" -type d -exec chmod 755 {} +
+ find "${srcdir}/data/noarch/game" -type f -exec chmod 644 {} +
+ mkdir -p "${pkgdir}/opt/${_dlcparent}"
+ mv "${srcdir}/data/noarch/game/"* "${pkgdir}/opt/${_dlcparent}"
+}