summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 37 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d137d8d115a..20d1b2f9f49f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,51 @@
# Maintainer: Krakn - Dan.Ray.Beste@gmail.com
# Thanks to: Ainola for the base PKGBUILD (gog-undertale)
+# All dependencies are included with the gog_owlboy_$version.sh file.
+# For good measure I was able to track all but 2 down:
+# libmojoshader - https://icculus.
+# libXNAFileDialog - https://github.com/flibitijibibo/XNAFileDialog
+
pkgname=gog-owlboy
pkgver=2.0.0.1
pkgrel=1
pkgdesc="Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!"
url="http://www.owlboygame.com/"
-license=('custom')
-arch=('i686' 'x86_64')
-# Dependencies are included with the gog_owlboy_$version.sh file.
-depends_x86_64=()
-depends_i686=()
-# If Firejail is installed, this application will be sandboxed automatically.
-optdepends=('firejail: Automatically sandbox this application from your OS')
+license=(
+ 'custom'
+)
+arch=(
+ 'i686'
+ 'x86_64'
+)
+depends_x86_64=(
+ 'libogg'
+ 'libvorbis'
+ 'openal'
+ 'sdl2'
+)
+depends_i686=(
+ 'lib32-libogg'
+ 'lib32-libvorbis'
+ 'lib32-openal'
+ 'lib32-sdl2'
+)
+optdepends=(
+ 'firejail: Automatically sandbox this application from your OS'
+)
source=(
"gog://${pkgname//-/_}_${pkgver}.sh"
"${pkgname}.desktop"
- "$pkgname")
+ "$pkgname"
+)
sha256sums=(
- "76958e0bb434d2514873aaddb892bc6c7055c39799ecde5f62a56345136853fc"
- "8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2"
- "22b307b01c96852220e1be33e1cfa19410c7dd009135540e6d48ed35bace17f0"
+ '76958e0bb434d2514873aaddb892bc6c7055c39799ecde5f62a56345136853fc'
+ '8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2'
+ '160b4d0fb275d3c1d4d6d574ca4085579e944e67dd32bd0a0c6e79f2e3d105a6'
+)
+DLAGENTS=(
+ "gog::/usr/bin/echo %u Download the GOG file to $PWD or set up a gog:// DLAGENT."
)
-
-# You need to download the gog.com installer file manually or with lgogdownloader.
-DLAGENTS+=("gog::/usr/bin/echo %u Download the GOG file to \"$PWD\" or set up a gog:// DLAGENT.")
-
-# Prevent compressing final package
-PKGEXT=".pkg.tar"
package(){
cd "${srcdir}"
@@ -52,5 +70,6 @@ package(){
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 "${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "${srcdir}/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
}