summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a3e9e793446..0f68d9bf2627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: IroAlexis <iroalexis@outlook.fr>
_pkgname=gogextract
pkgname=${_pkgname}-git
-pkgver=r2.6601b32
-pkgrel=2
+pkgver=r96.e32f22d
+pkgrel=1
pkgdesc='Unpack GOG Linux installers'
arch=('any')
-url='https://github.com/Yepoleb/gogextract'
-license=('MIT')
-depends=('python')
+url='https://framagit.org/IroAlexis/gogextract'
+license=('GPL-3.0-or-later')
+depends=('libzip')
makedepends=('git')
provides=("${_pkgname}")
source=("git+${url}.git")
@@ -19,10 +19,16 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/${_pkgname}"
+
+ make
+}
+
package() {
- install -Dm755 "${_pkgname}/${_pkgname}.py" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "${_pkgname}/README.md"
install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" "${_pkgname}/LICENSE"
}
-# vim: ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: \ No newline at end of file