summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a398163cdfc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Bailey Kasin <bailey@gingertechnology.net> (https://angrysysadmins.tech)
+
+pkgname=gogios-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="Checks to see if required services are still running on important machines."
+arch=('x86_64')
+url="https://angrysysadmins.tech"
+license=('MIT')
+depends=(
+ 'dotnet-sdk'
+ 'dotnet-runtime'
+ 'dotnet-host'
+)
+optdepends=('nginx')
+source=("https://github.com/BKasin/Gogios/releases/download/v${pkgver}/gogios-${pkgver}.deb")
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+noextract=("gogios-${pkgver}.deb")
+sha256sums=('32137aa91a691189aa370560fb7e8214f03ae96328854bfba236870f1912e5fe')
+
+package() {
+ bsdtar -O -xf gogios-${pkgver}.deb data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+}
+