summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83c085be302d..a34ca5fc6226 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=goland
pkgname=(goland goland-jre)
pkgver=173.3531.21
-pkgrel=1
+pkgrel=2
pkgdesc='Capable and Ergonomic Go IDE'
arch=('x86_64' 'i686')
url='https://www.jetbrains.com/go/'
@@ -18,6 +18,7 @@ sha512sums=('db2deb4e52fb4135e3fb27c63a181c34acddf61dd2bedf81e50144a85b3e9bcb1a7
package_goland() {
optdepends=('goland-jre: JetBrains custom Java Runtime (Recommended)'
'java-runtime>=8: JRE - Required if goland-jre is not installed')
+ conflicts=('gogland')
replaces=('gogland')
install -d -m 755 "${pkgdir}/opt/"
@@ -34,6 +35,7 @@ package_goland() {
}
package_goland-jre() {
+ conflicts=('gogland-jre')
replaces=('gogland-jre')
install -d -m 755 "${pkgdir}/opt/${pkgbase}"