summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2264815c67f..be5a017bceef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Chipster Julien <julien dot chipster @ archlinux dot fr>
pkgname=gonsupdate
url="https://github.com/Chipsterjulien/gonsupdate"
-pkgver=0.1
-pkgrel=1
+pkgver=0.0.1
+pkgrel=2
pkgdesc="If necessary, update your ip for nsupdate"
arch=('any')
license=('WTFPL')
+backup=('etc/gonsupdate/gonsupdate.toml')
makedepends=(go)
options=('!strip')
source=($pkgname-$pkgver.tar.gz)
@@ -32,13 +33,18 @@ build() {
cd "$_builddir"
go build || return 1
+
+ if [ $GOPATH_exist == 0 ]; then
+ rm -rf ~/.gopath
+ export GOPATH=
+ fi
}
package() {
cd "$_builddir"
# gonsupdate.toml
- install -Dm644 cfg/"$pkgname".toml \
+ install -Dm644 cfg/"$pkgname"_sample.toml \
"$pkgdir"/etc/$pkgname/gonsupdate_sample.toml || return 1
# Create log directory
@@ -58,4 +64,4 @@ package() {
"$pkgdir"/usr/bin/$pkgname || return 1
}
-sha512sums=('1ed468fbcc41adb6510cb8f52b22104e3ea31139fb2c49d7e0b05456cc07b045de028e068193b44e254d6ad199102db1689e26cc9f757cf5ba0899b091dccccc')
+sha512sums=('ec0afd88babe158add0fddf228c719f95e271e694b659ae0261c673a2da316806756e7d7c4e6a531a4a696c8190dd0f2e9f015ce175fee5330c8c2b7946fa00f')