summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8b1ece6a6cd..b81f572725f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,20 +17,27 @@
pkgname='google-compute-engine'
pkgver=20210113.00
-pkgrel=1
+pkgrel=2
pkgdesc='Linux Guest Environment for Google Compute Engine'
arch=('any')
url='https://github.com/GoogleCloudPlatform/guest-configs'
license=('Apache')
depends=('google-compute-engine-oslogin' 'google-guest-agent')
source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/$pkgver.tar.gz"
- 'google-compute-engine.install')
+ 'google-compute-engine.install'
+ 'google_set_hostname.patch')
sha256sums=('4d30fcfa368507f219ecf7e884442e5b556fbaec3f3367dc5c8b116f63be2977'
- '9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7')
+ '9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7'
+ '5cef3677dd373e81370ef6730643ba9dd20fb3bf47260e825ad37417da4fc6c3')
install='google-compute-engine.install'
+prepare() {
+ cd "$srcdir/guest-configs-$pkgver"
+ patch --strip=1 --input="$srcdir/google_set_hostname.patch"
+}
+
package() {
- cd "guest-configs-$pkgver"
+ cd "$srcdir/guest-configs-$pkgver"
install -m644 -Dt "$pkgdir/etc/modprobe.d" src/etc/modprobe.d/*
install -m644 -Dt "$pkgdir/etc/sysctl.d" src/etc/sysctl.d/*
install -m644 -Dt "$pkgdir/usr/lib/udev/rules.d" src/lib/udev/rules.d/*