summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 878f66ba05ca..658c67de9a9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=google-docs-nativefier
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Electron wrapper for the Google Docs web application"
arch=(x86_64)
license=(MIT)
@@ -11,16 +11,19 @@ source=($pkgname.png
$pkgname.desktop)
makedepends=(nodejs nodejs-nativefier npm)
sha256sums=('5231652761dce688ddd2f4b2a5b958fd5486acaa181ec239fd9d330d835b5bbb'
- 'e7a2eacb79e13849f616ad148adbd2fe570db775a2dd211ba0912292885492d6')
+ 'e3f241fc5eba29bf3f5f4ade5fb7cf4ca9426a1ddc34548d7224e5b372db49e4')
-_instname=google-docs
+_instname=GoogleDocs
build() {
nativefier "https://docs.google.com/" \
--icon $pkgname.png \
--maximize \
- --internal-urls "(accounts|docs)\.google" \
- --name "Google Docs"
+ --name "$_instname" \
+ --user-agent "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" \
+ --internal-urls "(.*?docs\.google\.com.*?|.*?accounts\.google\.com.*?)" \
+ --single-instance \
+ --electron-version 7.1.11
}
package() {