summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ff2cd870290..dd33327e5f15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Sébastien Feugère <smonff@riseup.net>
-# Contributor: Alex Kubica <alexkubicail@gmail.com>
+# Maintainer: Alex Kubica <alexkubicail@gmail.com>
+# Contributor: Sébastien Feugère <smonff@riseup.net>
pkgname=gopanda
pkgver=2
-pkgrel=3
+pkgrel=4
pkgdesc="Client for the Pandanet-IGS go Server"
arch=('i686' 'x86_64')
-url="http://pandanet-igs.com/communities/$pkgname$pkgversion"
+url="http://pandanet-igs.com/communities/${pkgname}${pkgversion}"
license=('custom')
depends=('libnotify'
'alsa-lib'
@@ -15,12 +15,12 @@ depends=('libnotify'
'nss')
options=(!strip)
source=(LICENSE)
-source_i686=("http://pandanet-igs.com/$pkgname$pkgver/installer/stable/linux-32/$pkgname$pkgver-linux-32.tar.gz")
-source_x86_64=("http://pandanet-igs.com/$pkgname$pkgver/installer/stable/linux-64/$pkgname$pkgver-linux-64.tar.gz")
+source_i686=("http://pandanet-igs.com/${pkgname}${pkgver}/installer/stable/linux-32/${pkgname}${pkgver}-linux-32.tar.gz")
+source_x86_64=("http://pandanet-igs.com/${pkgname}${pkgver}/installer/stable/linux-64/${pkgname}${pkgver}-linux-64.tar.gz")
md5sums=('c5951d02adb28f6b333d913ae2f92df0')
md5sums_i686=('170e380003a712267e3e85c0fe38011a')
md5sums_x86_64=('d1fcd13d8de0f2c0331ee0a9cb58a58a')
-_DEST="/usr/share/$pkgname"
+_DEST="/opt/${pkgname}"
_CLIENT="GoPanda2"
_DESKTOP="/usr/share/applications/${_CLIENT}.desktop"
_ICON="/usr/share/pixmaps/${_CLIENT}.png"
@@ -32,11 +32,8 @@ package() {
cd "$srcdir/${_CLIENT}"
# Program
- install -dm755 "${pkgdir}${_DEST}"
- install -m755 "${_CLIENT}" "${pkgdir}${_DEST}"
- install -m644 "nw.pak" "${pkgdir}${_DEST}"
- install -m644 "libffmpegsumo.so" "${pkgdir}${_DEST}"
- install -m644 "icudtl.dat" "${pkgdir}${_DEST}"
+ install -Dm755 "${_CLIENT}" "${pkgdir}${_DEST}/${_CLIENT}"
+ install -m644 nw.pak libffmpegsumo.so icudtl.dat "${pkgdir}${_DEST}"
# Link to program
install -dm755 "${pkgdir}/usr/bin"