summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9f873770239..2e73500dbc57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,23 @@
pkgname=gorun
pkgver=19
-pkgrel=2
+pkgrel=3
pkgdesc="Program to run Go programs as if they were scripts"
arch=('x86_64' 'i686')
-url="http://launchpad.net/gorun/"
+url="https://wiki.ubuntu.com/gorun"
license=('GPL3')
makedepends=('go')
options=(!strip)
-source=("http://bazaar.launchpad.net/~niemeyer/gorun/trunk/download/head:/gorun.go-20110311220116-kde0kha0feljz1pm-3/gorun.go")
-sha256sums=('a5655571c1e89c267e14ce8f6944f9f4e88e13ecef7783c8a9b4eb21f94bd4cf')
+source=("git+https://github.com/erning/gorun")
+sha256sums=('SKIP')
build() {
- cd "$srcdir"
-
- go build -o $pkgname
+ cd "$srcdir/$pkgname"
+ GO111MODULE=off go build -o $pkgname
}
package() {
- cd "$srcdir"
-
+ cd "$srcdir/$pkgname"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
}