summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c2289912dcf..4d698f2e7526 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=gospt
-pkgver=0.0.3
+pkgver=0.0.5
pkgrel=1
pkgdesc='Spotify TUI And CLI written in Go'
arch=('x86_64')
@@ -7,7 +7,7 @@ url="https://gitea.asdf.cafe/abs3nt/$pkgname"
license=('GPL')
makedepends=('go')
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('0f47f157680df65dcded6fa8815ad4339eef13e6e922327f0e3134b1f9abbbaf')
+sha256sums=('391bccbf432c11c0744aa401db8bb796203f900b6714b1c851cc28ea015845bd')
prepare(){
cd "$pkgname"
@@ -22,6 +22,9 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -o build ./...
+ ./build/$pkgname completion zsh > build/gospt_zsh
+ ./build/$pkgname completion bash > build/gospt_bash
+ ./build/$pkgname completion fish > build/gospt_fish
}
check() {
@@ -32,4 +35,9 @@ check() {
package() {
cd "$pkgname"
install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 build/gospt_zsh "$pkgdir"/usr/share/zsh/site-functions/_gospt
+ install -Dm644 build/gospt_bash "$pkgdir"/usr/share/bash-completion/completions/gospt
+ install -Dm644 build/gospt_fish "$pkgdir"/usr/share/fish/vendor_completions.d/gospt.fish
+
+
}