summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0afa936ba884..e220d2c6f7c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=gotask-taskfile
_pkgname=task
pkgver=3.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="A task runner / simpler Make alternative written in Go. Installs as gtask to allow coexistance with taskwarrior."
arch=('any')
url="https://github.com/go-task/task"
license=('MIT')
provides=("$pkgname")
conflicts=("$pkgname")
-makedepends=('go' 'git')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
@@ -31,6 +31,12 @@ build() {
go build -v -o build ./...
}
+check() {
+ cd "$_pkgname-$pkgver"
+
+ go test ./...
+}
+
package() {
cd "$_pkgname-$pkgver"