summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ae9cc8b4525..11fd20dac29b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gotop
pkgver=3.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='A terminal based graphical activity monitor inspired by gtop and vtop'
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://github.com/cjbassi/gotop"
@@ -11,12 +11,17 @@ license=(AGPL3)
provides=(gotop)
conflicts=(gotop)
makedepends=("go" "git")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cjbassi/gotop/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('d5147080bb6057f0bf0900b38438e89aa066959c845bdd4c84a9c9fe478b176f')
build() {
cd "${srcdir}"/${pkgname}-${pkgver}
- go build
+ go build \
+ -gcflags "all=-trimpath=${PWD}" \
+ -asmflags "all=-trimpath=${PWD}" \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ -mod vendor \
+ .
}
package() {