summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8059a000fe30..db95a56807a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname='gourmand'
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A recipe manager for desktop that can import recipes"
arch=('any')
url="https://github.com/GourmandRecipeManager/gourmand"
license=('GPL')
depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests')
-makedepends=('python-pip')
+makedepends=('python-pip' 'gendesk')
checkdepends=()
optdepends=(
'python-beautifulsoup4: Webpage import plugin'
@@ -23,7 +23,12 @@ conflicts=('gourmet')
source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')
+prepare() {
+ gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
+}
+
package() {
# https://wiki.archlinux.org/title/Python_package_guidelines#pip
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}