summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf54749397bd..8059a000fe30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,18 @@ pkgdesc="A recipe manager for desktop that can import recipes"
arch=('any')
url="https://github.com/GourmandRecipeManager/gourmand"
license=('GPL')
-depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy')
+depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy' 'python-lxml' 'python-cairo' 'python-requests')
makedepends=('python-pip')
checkdepends=()
-optdepends=('python-beautifulsoup4: Webpage import plugin')
+optdepends=(
+ 'python-beautifulsoup4: Webpage import plugin'
+ 'python-scrape-schema-recipe: Webpage import plugin'
+ 'python-selenium'
+ 'python-keyring'
+ 'python-ebooklib: EPub export plugin'
+ 'python-reportlab: Printing & PDF export plugin'
+ 'python-gtkspellcheck: Spell checking plugin'
+ )
conflicts=('gourmet')
source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')