summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27376b3f33bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Ashwin Vishnu <ashwinvis+arch at pr0t0nm4il dot com>
+
+pkgname=govarnam-git
+pkgver=1.6.0.r8.g35460dc
+pkgrel=1
+pkgdesc="Transliteration and reverse transliteration for Indian languages"
+arch=('x86_64')
+url="https://varnamproject.github.io/"
+license=('AGPL')
+makedepends=('go')
+source=("${pkgname}::git+https://github.com/varnamproject/govarnam.git")
+sha256sums=('SKIP')
+provides=('govarnam' 'varnamcli')
+
+prepare() {
+ cd "$pkgname"
+ # mkdir -p build
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//g'
+}
+
+build() {
+ cd "$pkgname"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ PREFIX=/usr make
+}
+
+# check() {
+# cd "$pkgname"
+# make test
+# }
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 varnamcli "$pkgdir"/usr/bin/varnamcli
+ install -Dm644 libgovarnam.so "$pkgdir"/usr/lib/libgovarnam.so
+}
+