summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6855775adeb0..4b0089054e10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Ashwin Vishnu <ashwinvis+arch at pr0t0nm4il dot com>
pkgname=govarnam-ibus-git
-pkgver=1.6.2.r1.g76e9421
+pkgver=1.6.2.r3.g38b3d0b
pkgrel=1
pkgdesc="IBus engine for GoVarnam providing Indian language input method - Git version"
arch=('x86_64')
@@ -11,8 +11,11 @@ license=('AGPL')
makedepends=('go' 'git')
depends=('govarnam' 'ibus')
source=("${pkgname}::git+https://github.com/varnamproject/govarnam-ibus.git"
- "git+https://github.com/varnamproject/govarnam.git")
-sha256sums=('SKIP' 'SKIP')
+ "git+https://github.com/varnamproject/govarnam.git"
+ "wayland-fix.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ '02479dff418290567b2748d6f23124474fe7b8f7eb89694464c4eb0fa843ed4f')
provides=('govarnam-ibus')
pkgver() {
@@ -20,6 +23,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//g'
}
+prepare() {
+ cd "$pkgname"
+ git am ../wayland-fix.patch
+}
+
build() {
cd "$pkgname"
export CGO_CPPFLAGS="${CPPFLAGS}"
@@ -27,7 +35,7 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- PREFIX=/usr make ubuntu-14
+ make INSTALL_PREFIX=/usr ubuntu-14
}
# check() {