summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d915b4956cb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alexey Trifonov <otaku [at] rambler dot ru>
+# Contributor: Tesx <tesfabpel@gmail.com>
+pkgname=goxel-voxel-editor-git
+pkgver=0.10.0.r69.5ce340a
+pkgrel=1
+pkgdesc="Open Source 3D voxel editor for Mac, Windows and Linux. Git version."
+arch=('i686' 'x86_64')
+conflicts=('goxel')
+provides=('goxel')
+url="https://guillaumechereau.github.io/goxel/"
+license=('GPL3')
+groups=()
+makedepends=(scons pkg-config)
+depends=(glfw gtk3)
+source=(
+ "git+https://github.com/guillaumechereau/goxel.git"
+ "goxel.desktop"
+)
+sha256sums=(
+ 'SKIP'
+ '9b29df7405a9593396bc7ea810dc2871cce7c4ee474c1fa56d32f56c2ca2d921'
+)
+
+_gitname=goxel
+
+pkgver() {
+
+ cd $_gitname
+ printf "%s" "$(git describe --first-parent --long --tags | sed 's/v//g;s/\([^-]*-\)g/r\1/;s/-/./g')"
+
+}
+
+build() {
+ cd $_gitname
+ make release
+}
+
+package() {
+ install -Dm644 goxel.desktop "$pkgdir/usr/share/applications/goxel.desktop"
+ install -Dm644 goxel/icon.png "$pkgdir/usr/share/icons/goxel.png"
+
+ cd $_gitname
+ install -Dm755 goxel "$pkgdir/usr/bin/goxel"
+}