summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d02cfe1cc871
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Simon Gomizelj <simongmzlj@gmail.com>
+
+pkgname=gpg-tools-git
+pkgver=1
+pkgrel=1
+pkgdesc="Wrapper for gpg-agent integration"
+arch=('i686' 'x86_64')
+url="http://github.com/vodik/gpg-tools"
+license=('GPL')
+depends=('gnupg')
+makedepends=('git' 'ragel')
+conflicts=('gpg-tools')
+provides=('gpg-tools')
+source=('git+git://github.com/vodik/gpg-tools.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "gpg-tools"
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ make -C "gpg-tools"
+}
+
+package() {
+ make -C "gpg-tools" DESTDIR="$pkgdir" install
+}
+
+# vim: ft=sh syn=sh et