summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbc8e48495a3..22d0f56be25b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# https://github.com/orhun/pkgbuilds
pkgname=gpg-tui-git
-pkgver=0.7.4.r0.g148c99a
+pkgver=0.8.0.r0.g9d2e6c5
pkgrel=1
pkgdesc="A terminal user interface for GnuPG (git)"
arch=('x86_64')
url="https://github.com/orhun/gpg-tui"
license=('MIT')
-depends=('libxcb' 'gpgme')
+depends=('libxcb' 'libxkbcommon' 'gpgme')
makedepends=('rust' 'python' 'git')
optdepends=(
'xplr: for file selection support'
@@ -21,25 +21,26 @@ provides=("${pkgname%-git}")
source=("git+${url}")
sha256sums=('SKIP')
-prepare() {
+pkgver() {
cd "${pkgname%-git}"
- mkdir completions/
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-pkgver() {
+prepare() {
cd "${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ mkdir completions/
+ cargo fetch --locked
}
build() {
cd "${pkgname%-git}"
- cargo build --release --locked
- OUT_DIR=completions/ cargo run --release --bin completions
+ cargo build --release --frozen
+ OUT_DIR=completions/ cargo run --release --bin gpg-tui-completions
}
check() {
cd "${pkgname%-git}"
- cargo test --locked
+ cargo test --frozen
}
package() {
@@ -48,6 +49,7 @@ package() {
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm 644 "man/${pkgname%-git}.1" -t "$pkgdir/usr/share/man/man1"
+ install -Dm 644 "man/${pkgname%-git}.toml.5" -t "$pkgdir/usr/share/man/man5"
install -Dm 644 "completions/${pkgname%-git}.bash" "$pkgdir/usr/share/bash-completion/completions/${pkgname%-git}"
install -Dm 644 "completions/${pkgname%-git}.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
install -Dm 644 "completions/_${pkgname%-git}" -t "$pkgdir/usr/share/zsh/site-functions"