summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 33 insertions, 45 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e698485b2666..752bd00d9809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,44 @@
-# Maintainer: Timmy Yao <timmy.yao@outlook.com.au>
+# Maintainer: Ruben Bekaert <bekaertruben@gmail.com>
+
pkgname=gplates
-pkgver=2.1.0
+
+pkgdesc="GPlates is a plate tectonics program. Manipulate reconstructions of geological and paleogeographic features through geological time. Interactively visualize vector, raster and volume data."
+url="https://www.gplates.org"
+license=(GPLv2)
+
+arch=(any)
+pkgver=2.4.0
pkgrel=2
-pkgdesc="Desktop software for the interactive visualisation of plate-tectonics"
-arch=(x86_64)
-url="https://www.gplates.org/"
-license=('GPL')
-depends=(qt4 qwt-qt4 gdal)
-makedepends=(cmake glu glew python2 boost mesa cgal proj)
-source=("https://downloads.sourceforge.net/project/gplates/gplates/2.1/gplates-$pkgver-unixsrc.tar.bz2"
- "no-ansi.patch"
- "icon.png"
- "gplates.desktop")
-md5sums=('770758823ac480e40213a5b284d273fc'
- '57f9fb5b981456bdc874094d35488763'
- '938ef5a002905872a633665637a45d77'
- '1127c6a17abfa7500280fd09ce475a15')
+
+# Some of these dependencies are not listed in the documentation, but are used anyways. These might be optional.
+depends=(libgl glu glew python python-numpy boost qt5-base qt5-svg qt5-xmlpatterns gdal cgal proj qwt zlib graphviz gmp mpfr arrow)
+makedepends=(cmake doxygen patchelf)
+
+source=(
+ "${pkgname}_${pkgver}_src.tar.bz2::https://www.earthbyte.org/download/9758/"
+ "icon.png"
+ "gplates.desktop"
+)
+sha256sums=(
+ "9ae877f2fa10c3526362d699f65b6a81908d760c416d85fe5e7b8193fee8aab8"
+ "9335fb98b21bc03c1cbec21ca945bded6ac60f66bb14997654b1829c1bd7265b"
+ "c9cf5e841e3bc1e730c5c1fa00a1137f532de4c2859637e67d1682f021eebb11"
+ )
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np2 -i "$srcdir/no-ansi.patch"
+ cd "${srcdir}/${pkgname}_${pkgver}_src"
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- QTDIR=/usr/lib/qt4 cmake \
- -DQT_QMAKE_EXECUTABLE=/usr/lib/qt4/bin/qmake \
- -DQT_UIC_EXECUTABLE=/usr/lib/qt4/bin/uic \
- -DQT_MOC_EXECUTABLE=/usr/lib/qt4/bin/moc \
- -DQT_HEADERS_DIR=/usr/include/qt4 \
- -DQT_QTCORE_INCLUDE_DIR:PATH=/usr/include/qt4/QtCore \
- -DQT_QTGUI_INCLUDE_DIR:PATH=/usr/include/qt4/QtGui \
- -DQT_QTNETWORK_INCLUDE_DIR:PATH=/usr/include/qt4/QtNetwork \
- -DQT_QTOPENGL_INCLUDE_DIR:PATH=/usr/include/qt4/QtOpenGL \
- -DQT_QTSQL_INCLUDE_DIR:PATH=/usr/include/qt4/QtSql \
- -DQT_QTSVG_INCLUDE_DIR:PATH=/usr/include/qt4/QtSvg \
- -DQT_QTTEST_INCLUDE_DIR:PATH=/usr/include/qt4/QtTest \
- -DQT_QTXMLPATTERNS_INCLUDE_DIR:PATH=/usr/include/qt4/QtXmlPatterns \
- -DQT_QTXML_INCLUDE_DIR:PATH=/usr/include/qt4/QtXml \
- -DQWT_INCLUDE_DIR:PATH=/usr/include/qwt-qt4 \
- -DQWT_LIBRARY:PATH=/usr/lib/libqwt-qt4.so \
- -DCMAKE_INSTALL_PREFIX="/usr/" \
- -DCMAKE_BUILD_TYPE=Release \
- .
- make
+ cd "${srcdir}/${pkgname}_${pkgver}_src"
+
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DCMAKE_BUILD_TYPE=Release .
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
-
- install "${srcdir}/icon.png" -t "${pkgdir}/usr/share/${pkgname}"
- install -Dm644 "${srcdir}/gplates.desktop" -t "${pkgdir}/usr/share/applications"
+ cd "${srcdir}/${pkgname}_${pkgver}_src"
+ make DESTDIR="${pkgdir}/" install
+ install "${srcdir}/icon.png" -t "${pkgdir}/usr/share/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
}
-