summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 38 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45a23cb0d1e7..ed32f8df3a54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,57 @@
# Maintainer: Darryl Pogue <darryl@dpogue.ca>
-pkgname="gplugin"
-pkgver=0.29.0
-pkgrel=1
+pkgbase=gplugin
+_pkgname=gplugin
+pkgname=(gplugin gplugin-docs)
+pkgver=0.38.1
+pkgrel=2
arch=('i868' 'x86_64')
-pkgdesc="A GObject based library that implements a reusable plugin system"
license=("LGPL2")
-url="https://bitbucket.org/gplugin/gplugin"
-depends=("gtk3")
+url="https://keep.imfreedom.org/gplugin/gplugin"
+pkgdesc="A GObject based library that implements a reusable plugin system"
+depends=("gtk3" "gtk4" "glib-perl" "lua" "python")
makedepends=("meson"
"mercurial"
"gcc"
"gobject-introspection"
"pkg-config"
"help2man"
- "gettext")
+ "gettext"
+ "gi-docgen"
+ "lua-lgi"
+ "perl-glib-object-introspection"
+ "python-gobject"
+ "vala")
options=('strip' '!debug' 'staticlibs')
-source=("$pkgname::hg+https://bitbucket.org/$pkgname/$pkgname#tag=v$pkgver")
+source=("$pkgname::hg+https://keep.imfreedom.org/$_pkgname/$_pkgname/#tag=v$pkgver")
sha256sums=('SKIP')
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
+}
+
build() {
- meson --prefix /usr --buildtype=plain -D doc=false -D perl=false -D python=false -D lua=false -D tcl=false "$srcdir/$pkgname" build
+ arch-meson gplugin build
ninja -C build
}
-package() {
+package_gplugin() {
+ depends=("gtk3" "gtk4" "glib-perl" "lua" "python")
DESTDIR="$pkgdir" ninja -C build install
+
+ cd "$pkgdir"
+ _pick docs usr/share/doc/gplugin*
+}
+
+
+package_gplugin-docs() {
+ pkgdesc+=" (documentation)"
+ depends=()
+ mv docs/* "$pkgdir"
}