summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 39 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 538894c1c350..80ceb4067549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
-
+# Co-Maintainer: Solomon Choina <shlomochoina@gmail.com>
_pkgbase=gplugin
-pkgname="$_pkgbase-hg"
-pkgver=993.307728b2f727
-pkgrel=1
+pkgbase="$_pkgbase-hg"
+pkgname=("$_pkgbase-hg" "$_pkgbase-docs-hg")
+pkgver=2003.b8f1ba3e24fc
pkgdesc="GObject based library that implements a reusable plugin system"
+pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
-url="https://guifications.org/"
-license=('GPL')
-depends=('glib2' 'gobject-introspection-runtime')
-makedepends=('mercurial' 'cmake' 'gobject-introspection' 'gtk3'
- 'python-gobject' 'lua-lgi' 'libxslt' 'help2man')
-optdepends=('gtk3: for GTK+ support'
- 'python-gobject: for Python support'
- 'lua-lgi: for Lua support')
+url="https://keep.imfreedom.org/gplugin/gplugin/"
+license=('LGPL-2.0-or-later')
+makedepends=('mercurial' 'meson' 'gobject-introspection' 'gtk3' 'perl-glib-object-introspection'
+ 'python-gobject' 'lua-lgi' 'libxslt' 'help2man' 'vala' 'gi-docgen' 'gtk4')
provides=("$_pkgbase=0.0.23")
conflicts=("$_pkgbase")
-source=("$_pkgbase::hg+https://bitbucket.org/gplugin/main#branch=develop")
+source=("$_pkgbase::hg+https://keep.imfreedom.org/gplugin/gplugin#branch=default")
sha256sums=('SKIP')
pkgver() {
@@ -25,21 +22,37 @@ pkgver() {
hg identify -ni | awk 'BEGIN{OFS=".";} {print $2,$1}'
}
-prepare() {
- mkdir -p "$srcdir/$_pkgbase/build"
- cd "$srcdir/$_pkgbase/build"
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_LIBDIR=lib
+build() {
+ arch-meson gplugin build -Dgtk4=enabled
+ meson compile -C build
}
-build() {
- cd "$srcdir/$_pkgbase/build"
- make
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
}
-package() {
- cd "$srcdir/$_pkgbase/build"
- make DESTDIR="$pkgdir/" install
+package_gplugin-hg() {
+ depends=('glib2' 'gtk4' 'lua')
+ optdepends=('gtk3: for GTK+ support'
+ 'python-gobject: for Python support'
+ 'lua53-lgi: for Lua support'
+ 'glib-perl: for perl support')
+
+ DESTDIR="$pkgdir" ninja -C build install
+
+ cd "$pkgdir"
+ _pick docs usr/share/doc
+}
+
+package_gplugin-docs-hg() {
+pkgdesc+=" (documentation)"
+ depends=()
+
+ mv docs/* "$pkgdir"
}