summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index edf738311bc5..3c7d1b9c349a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Jan Magnus Brevik <janmbrevik@gmail.com>
pkgname=gpodder-git
-pkgver=3.10.8.r0.g4e39b9b6
+pkgver=3.10.11.r0.g3199f936
pkgrel=1
pkgdesc='A podcast receiver/catcher'
license=('GPL3')
arch=('any')
url='http://gpodder.org/'
-depends=('hicolor-icon-theme' "python-"{cairo,dbus,gobject,mygpoclient,podcastparser})
-makedepends=('git' 'help2man' 'intltool')
+depends=(gtk3 python-cairo python-dbus python-gobject python-mygpoclient python-podcastparser)
+makedepends=(git help2man intltool)
optdepends=('ffmpeg: transcode audio files to mp3/ogg'
'gnome-bluetooth: transfer podcast via bluethooth'
'lame: converting ogg to mp3'
@@ -17,7 +17,8 @@ optdepends=('ffmpeg: transcode audio files to mp3/ogg'
'mutagen: audio tagging'
'python-eyed3: mp3 player sync support'
'python-html5lib: clickable links in GTK UI show notes'
- 'webkit2gtk: HTML show notes')
+ 'webkit2gtk: HTML show notes'
+ 'youtube-dl: for Youtube-dl extension')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
source=("${pkgname%-*}::git+https://github.com/gpodder/gpodder.git")
@@ -30,10 +31,10 @@ pkgver() {
build() {
cd "${pkgname%-*}"
- python setup.py build
+ make messages
}
package() {
cd "${pkgname%-*}"
- PYTHON=python DESTDIR=${pkgdir} make install
+ make DESTDIR="$pkgdir" install
}