summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9fdadbbb46e..863c015ccec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,25 @@
# Contributor: Earnestly <zibeon AT googlemail.com>
pkgname=gprbuild-bootstrap
-pkgver=2019
-pkgrel=2
+_gprbuild_ver=2020-20200429-19BD2
+_xmlada_ver=2020-20200429-19A99
+pkgver=2020
+pkgrel=1
pkgdesc="Static GPRbuild to bootstrap XML/Ada and GPRbuild itself"
arch=('i686' 'x86_64')
url='https://github.com/AdaCore/gprbuild/'
license=('GPL3')
depends=('gcc-ada')
-source=('https://community.download.adacore.com/v1/0c03c05cef70b85144ba0e624a46e8952183b666?filename=gprbuild-2019-20190517-194D8-src.tar.gz'
- 'https://community.download.adacore.com/v1/ce0b67754f149cd230ba842effeff0ab3033ed0c?filename=xmlada-2019-20190429-19B9D-src.tar.gz')
-sha1sums=(0c03c05cef70b85144ba0e624a46e8952183b666
- ce0b67754f149cd230ba842effeff0ab3033ed0c)
+_gprbuild_checksum=408ec35c3bb86bd227db3da55d3e1e0c572a56e3
+_xmlada_checksum=c799502295baf074ad17b48c50f621879c392c57
+source=("https://community.download.adacore.com/v1/${_gprbuild_checksum}?filename=gprbuild-$_gprbuild_ver-src.tar.gz"
+ "https://community.download.adacore.com/v1/${_xmlada_checksum}?filename=xmlada-$_xmlada_ver-src.tar.gz")
+sha1sums=("$_gprbuild_checksum"
+ "$_xmlada_checksum")
prepare() {
- cd "$srcdir/gprbuild-2019-20190517-194D8-src"
+ cd "$srcdir/gprbuild-${_gprbuild_ver}-src"
# GPRbuild hard-codes references to /usr/libexec, but ArchLinux packages
# must use /usr/lib instead.
@@ -28,7 +32,7 @@ prepare() {
}
build() {
- cd "$srcdir/gprbuild-2019-20190517-194D8-src"
+ cd "$srcdir/gprbuild-$_gprbuild_ver-src"
export GNATMAKEFLAGS="-j$(nproc)"
export DESTDIR="$srcdir/bootstrap"
@@ -36,7 +40,7 @@ build() {
./bootstrap.sh \
--prefix=/usr \
--libexecdir=/lib \
- --with-xmlada="$srcdir/xmlada-2019-20190429-19B9D-src"
+ --with-xmlada="$srcdir/xmlada-$_xmlada_ver-src"
}
package() {