summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6532c678860
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id$
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=gps-share
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Utility to share your GPS device on local network"
+arch=('x86_64' 'i686')
+url="https://github.com/zeenix/gps-share"
+license=('GPL')
+depends=('dbus')
+makedepends=('cargo' 'systemd')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/zeenix/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('3af9f03d2be9c55a6f21e1d2360ced00e980d301e54525cf8d9b29ddc426a10e')
+
+build() {
+ cd $pkgname-$pkgver
+ cargo build --release
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 target/release/gps-share "$pkgdir/usr/bin/gps-share"
+}