summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5775c82ff4a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Hinrich Harms <arch@hinrich.de>
+# Contributor: sylvain alborini <sylvain.alborini@gmail.com>
+# Maintainer: John Wallaby <drunken.wallaby@gmail.com>
+
+_pkgname=gpscorrelate
+pkgname=gpscorrelate-git
+pkgver=r68.365f6e1
+pkgrel=1
+pkgdesc='GPS Photo Correlation; Writes location data to EXIF tags using GPX files (command line and GTK interface).'
+url='https://github.com/freefoote/gpscorrelate'
+license=('GPL')
+source=('git+https://github.com/freefoote/gpscorrelate')
+sha256sums=('SKIP')
+arch=('any')
+depends=('libxml2' 'gtk2' 'exiv2')
+makedepends=('git')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/${_pkgname}
+ make prefix=/usr DESTDIR=$pkgdir install || return 1
+}
+
+
+# vim: ft=sh ts=2 sw=2 et