summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3af46d8c46ca..c9cca06833a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,10 +58,9 @@ wl_update() {
}
prepare() {
- cd ${_pkgname}-${_branch}
+ cd ${_pkgname}-${_branch}/lang
if [ "`curl ${_wl_hz}`" = "ok" ]; then
- cd lang
rename nb nb_NO *_nb.ts
wl_update Translations ${_pkgname,,}_
rename nb_NO nb *_nb_NO.ts
@@ -73,7 +72,9 @@ build() {
sed -i "s/\(VERSION = \).*/\1${pkgver}/" gpxsee.pro
- qmake CONFIG+=lrelease PREFIX=/usr gpxsee.pro
+ find lang -name "*.ts" -exec sh -c 'touch ${0//.ts/.qm}' {} \;
+ qmake CONFIG+=lrelease LRELEASE_DIR=lang PREFIX=/usr gpxsee.pro
+ rm -f lang/*.qm
make
}