summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd2b990d3b92..d8bbfdc4a89c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
pkgname=graphiql-app
-pkgver=0.6.0
+pkgver=0.7.2
pkgrel=1
pkgdesc='A light, Electron-based wrapper around GraphiQL.'
arch=(any)
@@ -15,7 +15,7 @@ source=(
graphiql-app.desktop
)
sha1sums=(
- 29be20fc3e8fcdc1ac344cb6510587ced67329f6
+ 13f2aff8ed8db66a7f2d0c7d74dd9820ff1f26d1
5291daa645b8f31fc8755e359d00fbfb21bf94db
ab93a32b54870933b1cd5d11a1112bb2318f08e4
53949e275525271e05b6b57d2c6685c5a72f4051
@@ -30,6 +30,9 @@ package() {
npm install
npm run build
+ find "$pkgdir" -type f -exec chmod 644 {} \;
+ find "$pkgdir" -mindepth 1 -type d -exec chmod 755 {} \;
+
install -Dm 755 "$srcdir/graphiql-app" "$pkgdir/usr/bin/graphiql-app"
install -Dm 644 "$srcdir/graphiql-app.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/graphiql-app.svg"
install -Dm 644 "$srcdir/graphiql-app.desktop" "$pkgdir/usr/share/applications/graphiql-app.desktop"