summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a570241fae79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgname=graphql-playground-electron
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="GraphQL IDE for better development workflows (GraphQL Subscriptions, interactive docs & collaboration)."
+arch=('x86_64')
+url="https://github.com/prisma/graphql-playground"
+license=('MIT')
+depends=('gtk3' 'gconf' 'nss' 'libxss')
+makedepends=('sed')
+source=("https://github.com/prisma/graphql-playground/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb"
+ "https://raw.githubusercontent.com/prisma/graphql-playground/v${pkgver}/LICENSE")
+sha256sums=('000f5de344a280f7027c37d478d6ea3684a357333460fe2ad612baa2e1b22e4e'
+ 'ee88d093c7c8e10dd41fc1c7b5ff51b2bbf57937b1b88eb3c1927f57743d59db')
+
+prepare() {
+ bsdtar xf data.tar.xz
+}
+
+package() {
+ mv opt "$pkgdir"
+ mv usr "$pkgdir"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+}