summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdc271bd9f67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Br Anthony VanBerkum <anthonyvbop AT gmail DOT com>
+# Contributor: LaƩrcio de Sousa <lbsousajr AT gmail DOT com>
+# Contributor: David Gippner davidgippner at googlemail dot com
+pkgbase=gregorio
+pkgname=$pkgbase
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Command-line tool to typeset Gregorian chant"
+url=http://gregorio-project.github.io
+arch=("i686" "x86_64")
+license=("GPL")
+depends=("texlive-core" "texlive-fontsextra" "texlive-bin" "texlive-formatsextra" "texlive-latexextra")
+conflicts=("gregorio-svn" "gregorio-git" "gregoriotex")
+provides=("gregorio")
+install=gregorio.install
+source=("https://github.com/gregorio-project/gregorio/releases/download/v3.0.2/gregorio-3.0.2.tar.gz")
+sha256sums=("da7e35e642f5bc40e55bf6e795513a225e6b7e80086a021e516c2daf69fc2e74")
+
+
+prepare() {
+ # Standardise src dir name without using a private variable.
+ mv "$srcdir/$pkgbase-$pkgver/" "$srcdir/$pkgbase/"
+ msg "Configuring..."
+ cd "$srcdir/$pkgbase/"
+ autoreconf -f -i
+ ./configure --prefix=/usr || return 1
+}
+
+build() {
+ msg "Compiling gregorio..."
+ cd "$srcdir/$pkgbase/"
+ make -j || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgbase/"
+ msg "Installing gregorio..."
+ make -j DESTDIR="$pkgdir/" install || return 1
+ msg "Installing fonts and TeX files..."
+ cd "$srcdir/$pkgbase/"
+ ./install-gtex.sh dir:$pkgdir/usr/share/texmf-dist || return 1
+}