summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 858689459cd3..542b5a2baa6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
# Contributor: big_gie nbigaouette . at . gmail.com
pkgname=gri-git
-pkgver=2.12.23
+pkgver=2.12.23.r20.gd9969d1
pkgrel=1
pkgdesc="A script-based language for scientific graphics programming"
arch=('i686' 'x86_64')
license=('GPL')
url="http://gri.sourceforge.net/"
depends=('perl')
-makedepends=('ghostscript' 'imagemagick6' 'texlive-core' 'perl-perl4-corelibs')
+conflicts=('gri')
+provides=('gri')
+makedepends=('git' 'ghostscript' 'imagemagick' 'texlive-core' 'perl-perl4-corelibs')
source=("git+https://github.com/dankelley/gri.git")
sha256sums=('SKIP')
-options=('!makeflags')
pkgver() {
cd ${pkgname%-git}
- git describe --tags | tr - . | cut -c2-
+ git describe --tags | sed 's+-+.r+' | tr - . | cut -c2-
}
build() {