summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3656f186466a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nicola Squartini <tensor5@gmail.com>
+
+pkgname=grin-git
+pkgver=r1382.ecb102e4
+pkgrel=1
+pkgdesc='Minimal implementation of the MimbleWimble protocol'
+arch=('i686' 'x86_64')
+url='https://github.com/mimblewimble/grin'
+license=('Apache')
+depends=('ncurses')
+makedepends=('clang' 'git' 'rust')
+source=('git+https://github.com/mimblewimble/grin.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd grin
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd grin
+
+ cargo build --release
+}
+
+package() {
+ cd grin
+
+ install -Dm755 -t "${pkgdir}/usr/bin" target/release/grin
+}