summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD96
1 files changed, 66 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb36a204f8da..d92b91c1cbe9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,80 +1,116 @@
-# Maintainer: Pedro A. López-Valencia <https://aur.archlinux.org/users/vorbote>
+# Maintainer: Pedro A. López-Valencia <https://aur.archlinux.org/users/toropisco>
pkgname=groff-git
-pkgver=1.22.4.37.gee0ce46b
+pkgver=1.23.0.598
pkgrel=1
pkgdesc="GNU Troff. Official git trunk."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.gnu.org/software/groff/"
license=('GPL')
-depends=('uchardet' 'netpbm' 'psutils' 'ghostscript')
-makedepends=('git' 'libxaw')
+depends=(
+ 'netpbm'
+ 'psutils'
+ 'uchardet'
+ 'ghostscript'
+ 'perl'
+ 'libxaw'
+ 'perl-file-homedir'
+)
+makedepends=('git')
+#
+# A provides here is a mere empty gesture. It doesn't work unless the core package includes the same.
+#
+provides=('groff')
+#
+# Absolutely necessary. Those who advocate for replaces only, have not used
+# pacman in anger apparently.
+#
conflicts=('groff')
-provides=('groff')
-source=("$pkgname::git://git.savannah.gnu.org/groff.git"
- "gnulib-git::git://git.sv.gnu.org/gnulib.git"
- 'site.tmac')
-optdepends=('libxaw: Enable gxditvew.')
-sha256sums=('SKIP'
- 'SKIP'
- 'af59ecde597ce9f8189368a7739279a5f8a391139fe048ef6b4e493ed46e5f5f')
+replaces=('groff')
+source=(
+ "$pkgname::git://git.savannah.gnu.org/groff.git"
+ "gnulib-git::git://git.sv.gnu.org/gnulib.git"
+ 'site.tmac'
+)
+
+b2sums=('SKIP'
+ 'SKIP'
+ 'c2906f83259261ba3927ca4870ce1035f04a66e9e2331a30961373d0b5dc2f62955b2cdf2ed8cebf927912a9b689fc9a3a25891dee0bdb301a41acea9dac56c3')
pkgver() {
cd "$srcdir/$pkgname"
- printf "%s" "$(git describe | sed 's/\-/\./g')"
+ printf "%s" "$(git describe | awk -F- '{ print $1"."$2 }')"
}
-
prepare() {
cd "$srcdir/$pkgname"
- sed -i.bak -e "s/\[2\.62\]/\[2\.63\]/" configure.ac
- ./bootstrap --gnulib-srcdir="$srcdir"/gnulib-git --bootstrap-sync --no-git
+ sed -i.bak -e "s/\[2\.62\]/\[2\.69\]/" configure.ac
+ ./bootstrap \
+ --gnulib-srcdir="$srcdir"/gnulib-git \
+ --force
}
build() {
mkdir -p "$srcdir/$pkgname"/build
cd "$srcdir/$pkgname"/build
-
local _configopts=(
--prefix=/usr
+ --enable-groff-allocator
--disable-rpath
--with-x
--with-appresdir=/usr/share/X11/app-defaults
--with-doc=yes
+ --with-uchardet=yes
)
-
../configure "${_configopts[@]}"
-
make
}
check() {
cd "$srcdir/$pkgname"/build
-
make check
}
package() {
cd "$srcdir/$pkgname"/build
-
- if [[ ${LANG/en_US} ]] || [[ ${LANG/es_CO} ]]; then
+ #
+ # Please report if your country uses ANSI paper sizes instead of ISO,
+ # be it officially or de facto---as is the case in Colombia, Mexico
+ # Chile or Canada---.
+ #
+ if
+ [[ ${LANG/en_US} ]] || \
+ [[ ${LANG/en_CA} ]] || \
+ [[ ${LANG/en_PH} ]] || \
+ [[ ${LANG/es_CO} ]] || \
+ [[ ${LANG/es_CL} ]] || \
+ [[ ${LANG/es_CR} ]] || \
+ [[ ${LANG/es_DO} ]] || \
+ [[ ${LANG/es_GT} ]] || \
+ [[ ${LANG/es_MX} ]] || \
+ [[ ${LANG/es_PA} ]] || \
+ [[ ${LANG/es_US} ]] || \
+ [[ ${LANG/fil_PH} ]] || \
+ [[ ${LANG/fr_CA} ]] || \
+ [[ ${LANG/ik_CA} ]] || \
+ [[ ${LANG/iu_CA} ]] || \
+ [[ ${LANG/shs_CA} ]] || \
+ [[ ${LANG/tl_PH} ]] \
+ then
make DESTDIR="$pkgdir/" PAPER=letter install
else
make DESTDIR="$pkgdir/" PAPER=A4 install
fi
-
+ #
## Copypaste from core package's PKGBUILD...
-
+ #
# add compatibility symlinks
+ #
ln -s eqn $pkgdir/usr/bin/geqn
ln -s tbl $pkgdir/usr/bin/gtbl
ln -s soelim $pkgdir/usr/bin/zsoelim
-
- # FS33760 - TERMCAP variables not followed
- # TODO: everyone is doing this - find out why upstream does not...
#
- # Having being privy to the whole thing since 2003, I wonder why people
- # still stick to this. Blech! Vorbote.
+ # FS33760 - TERMCAP variables not followed
#
cat $srcdir/site.tmac >> \
$pkgdir/usr/share/groff/site-tmac/man.local