summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f115a2387d0c..e3a9f7c31d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,16 @@
pkgname=gromacs-5.0-complete
pkgver=5.0.7
-pkgrel=4
+pkgrel=5
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
arch=('i686' 'x86_64')
-depends=('fftw' 'perl' 'libxml2' 'libsm')
-makedepends=('cmake')
+depends=('gcc5')
+optdepends=('cuda: Nvidia GPU support'
+ 'openmotif: needed for gmx view'
+ 'libx11: needed for gmx view')
+makedepends=('cmake' 'libxml2')
options=('!libtool')
source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
GMXRC.bash.cmakein.patch)
@@ -20,6 +23,10 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
#trajectory file format that can be read by
#VMD installation (e.g. AMBER's DCD format).
+#With gcc5 currently there are less errors in the tests
+# also the compilation is possible in cuda capable machines
+export CC=gcc-5
+export CXX=g++-5
prepare() {
cd ${srcdir}/gromacs-${pkgver}/scripts/
@@ -56,6 +63,7 @@ build() {
-DBUILD_SHARED_LIBS=ON \
-DGMX_X11=ON \
-DREGRESSIONTEST_DOWNLOAD=ON \
+ -DCMAKE_CXX_FLAGS="-std=c++11" \
-DCMAKE_INSTALL_LIBDIR=lib
make
}