summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 15 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ec2c71d91cf..7fff9a934a76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,28 @@
# Maintainer: hawkeye116477 <hawkeye116477 at gmail.com>
pkgname=groupsdomainsextractor
-pkgver=1.2.2
+_name=GDE
+pkgver=1.3.0
pkgrel=1
pkgdesc="Find all domains of specific group and copy it to clipboard"
-url="https://github.com/PolishFiltersTeam/ScriptsPlayground/blob/master/Readme_GDE.md"
-license=('MIT')
-depends=('python' 'python-certifi' 'python-urllib3' 'python-beautifulsoup4' 'python-tldextract' 'python-pysimplegui' 'python-appdirs' 'python-html5lib')
-makedepends=('unzip')
+url="https://github.com/FiltersHeroes/ScriptsPlayground/blob/master/Readme_GDE.md"
+license=('GPL3')
+depends=('python' 'python-beautifulsoup4' 'python-tldextract' 'python-requests' 'python-qtpy' 'qt5-python-bindings' 'python-platformdirs' 'gettext')
+makedepends=(python-setuptools python-build python-installer python-wheel)
arch=('any')
source=(
- "https://github.com/PolishFiltersTeam/ScriptsPlayground/releases/download/GDE-$pkgver/GDE.zip"
- "LICENSE.txt"
+ "https://github.com/FiltersHeroes/ScriptsPlayground/releases/download/GDE-$pkgver/GDE-$pkgver.tar.gz"
)
-sha256sums=('de399487adc99094dbaf00a22658befbb58b5d17ddcea8d3bc70c4e5de003363'
- '84c872a68ddd7b81d71673d560480dcaf0d83a7f694bb6521b2dbcebd2d2c912')
+sha256sums=('40ff6372ba05c2d7001c70f3086eb3ec6a16c5c7bcb1a6dfc0ddab5e973486ea')
-prepare() {
- mkdir -p "$srcdir"/opt/
- unzip GDE.zip -d "$srcdir"/opt/$pkgname/
- rm -rf "$srcdir"/opt/$pkgname/requirements.txt
+build() {
+ cd "$_name-$pkgver" || exit
+ python -m build --wheel --no-isolation
}
package()
{
- mkdir -p "$pkgdir"/opt/$pkgname/
- cp -R "$srcdir"/opt/* "$pkgdir"/opt/
-
- install -Dm755 /dev/stdin "$pkgdir/usr/bin/GDE" <<END
-#!/bin/bash
-python3 /opt/$pkgname/GDE.py "\$@"
-END
-
- install -Dm755 /dev/stdin "$pkgdir/usr/share/applications/GDE.desktop" <<END
-[Desktop Entry]
-Version=1.0
-Name=Groups Domains Extractor
-Name[pl]=Ekstraktor Domen Grup
-Comment=Finding all domains of specific group and copying it to clipboard
-Comment[pl]=Odnajdywanie wszystkich domen danej grupy i kopiowanie ich do schowka
-Exec=/usr/bin/GDE
-Terminal=false
-Type=Application
-Categories=Utility;Application;
-StartupNotify=false
-END
-
- install -Dm644 "$srcdir"/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_name-$pkgver" || exit
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ mkdir -p "$pkgdir"/usr/share/applications
+ install -Dm755 "$srcdir/$_name-$pkgver/GDE/shortcuts/share/applications/GDE.desktop" "$pkgdir"/usr/share/applications/
}