summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..846434db4987
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Copyright 2018 Google Inc. All Rights Reserved.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, version 3 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Maintainer: Lorenzo Castelli <lcastelli@gmail.com>
+# Maintainer: Samuel Littley <samuellittley@google.com>
+
+pkgname='growpart'
+pkgver=0.30
+pkgrel=1
+pkgdesc='Extends a partition to fill available space'
+arch=('any')
+url='https://launchpad.net/cloud-utils'
+license=('GPL3')
+source=("https://launchpad.net/cloud-utils/trunk/0.3/+download/cloud-utils-$pkgver.tar.gz"
+ 'growpartfs'
+ 'growpartfs@.service')
+sha256sums=('7360dd3d56aca48945a4a1943315f1633f82f3486ca5f065c6746bce274b8aa5'
+ '01576833fe3034c38f57b57b498f24ffe06263f6bcec25f79e57481aa854ac9b'
+ 'abb9633ea0a2bef1ae7c91b15267c1d901d63bb1d2f3caab76ecacc47a4b9c10')
+
+package() {
+ install -m755 -Dt "$pkgdir/usr/bin/" growpartfs
+ install -m644 -Dt "$pkgdir/usr/lib/systemd/system/" growpartfs@.service
+
+ cd "cloud-utils-$pkgver"
+ install -m755 -Dt "$pkgdir/usr/bin/" bin/growpart
+ install -m644 -Dt "$pkgdir/usr/share/man/man1/" man/growpart.1
+}