summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92c95450411a..a84549f48d04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
# Maintainer: Cody Schafer <dev@codyps.com>
pkgname=grpcurl
-pkgver=1.6.0
-pkgrel=1
+pkgver=1.7.0
+pkgrel=2
pkgdesc="Like cURL, but for gRPC: Command-line tool for interacting with gRPC servers"
arch=(x86_64)
url="https://github.com/fullstorydev/grpcurl"
license=('MIT')
makedepends=('go')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/fullstorydev/grpcurl/archive/v$pkgver.tar.gz")
-md5sums=('77082b483193d08ff6ff126269d1714d')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fullstorydev/grpcurl/archive/v$pkgver.tar.gz" go.sum.patch)
+md5sums=('e5b91174627819371cc6fb30fe53be18' SKIP)
# really, `grpcurl-bin` should be conflicting with us instead of the oposite
conflicts=('grpcurl-bin')
+prepare() {
+ cd "$pkgname-$pkgver"
+ # otherwise `-mod=readonly` causes go to fail as it needs to update go.sum
+ patch -R go.sum ../go.sum.patch
+}
build() {
cd "$pkgname-$pkgver"