summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e45f4719fd92..2af5773aef48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Cody Schafer <dev@codyps.com>
pkgname=grpcurl
-pkgver=1.8.0
-pkgrel=2
+pkgver=1.8.2
+pkgrel=1
pkgdesc="Like cURL, but for gRPC: Command-line tool for interacting with gRPC servers"
arch=(x86_64)
url="https://github.com/fullstorydev/grpcurl"
@@ -10,18 +10,11 @@ license=('MIT')
makedepends=('go')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/fullstorydev/grpcurl/archive/v$pkgver.tar.gz"
- file://0001-use-latest-version-of-protoreflect-212.patch
)
-md5sums=('6b8efb66f4281e3a09221dfa5d9b2fc3'
- '8b6c6b82b43bb22145ffc746e747e6b7')
+sha384sums=('1086ea3a60d644d98153d68bcc9ee94c87ba2914fe78e8d84323383f33814ca858f3496c0b513a4093affa930c9bbd32')
# really, `grpcurl-bin` should be conflicting with us instead of the oposite
conflicts=('grpcurl-bin')
-prepare() {
- cd "$pkgname-$pkgver"
- patch -Np1 -i "../0001-use-latest-version-of-protoreflect-212.patch"
-}
-
build() {
cd "$pkgname-$pkgver"
export CGO_CPPFLAGS="${CPPFLAGS}"