summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD127
1 files changed, 56 insertions, 71 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fd2b52b5f4c..9ec024062b41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ _IA32_EFI_IN_ARCH_X64="1"
## "1" to enable EMU build, "0" to disable
_GRUB_EMU_BUILD="0"
-_GRUB_EXTRAS_COMMIT="f2a079441939eee7251bf141986cdd78946e1d20"
-
+_GRUB_EXTRAS_COMMIT="136763a4cc9ca3a4f59d05b79eede2159d6f441e"
+_GNULIB_COMMIT="9ce9be2ef0cb1180e35dfe9dfbbe90d774b374bd"
_UNIFONT_VER="12.1.02"
[[ "${CARCH}" == "x86_64" ]] && _EFI_ARCH="x86_64"
@@ -21,14 +21,15 @@ _UNIFONT_VER="12.1.02"
pkgname='grub-libzfs'
pkgdesc='GNU GRand Unified Bootloader (2) - libzfs support'
-pkgver=2.02
-pkgrel=3
+_pkgver=2.04
+pkgver=${_pkgver/-/}
+pkgrel=1
epoch=2
url='https://www.gnu.org/software/grub/'
arch=('x86_64')
license=('GPL3')
backup=('etc/default/grub'
- 'etc/grub.d/40_custom')
+ 'etc/grub.d/40_custom')
install="${pkgname}.install"
options=('!makeflags')
@@ -37,52 +38,45 @@ replaces=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub')
provides=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub')
makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
- 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse2')
+ 'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse2')
depends=('sh' 'xz' 'gettext' 'device-mapper' 'zfs-utils')
optdepends=('freetype2: For grub-mkfont usage'
- 'fuse2: For grub-mount usage'
- 'dosfstools: For grub-mkrescue FAT FS and EFI support'
- 'efibootmgr: For grub-install EFI support'
- 'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
- 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
- 'mtools: For grub-mkrescue FAT FS support')
+ 'fuse2: For grub-mount usage'
+ 'dosfstools: For grub-mkrescue FAT FS and EFI support'
+ 'efibootmgr: For grub-install EFI support'
+ 'libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue'
+ 'os-prober: To detect other OSes when generating grub.cfg in BIOS systems'
+ 'mtools: For grub-mkrescue FAT FS support')
if [[ "${_GRUB_EMU_BUILD}" == "1" ]]; then
- makedepends+=('libusbx' 'sdl')
- optdepends+=('libusbx: For grub-emu USB support'
- 'sdl: For grub-emu SDL support')
+ makedepends+=('libusbx' 'sdl')
+ optdepends+=('libusbx: For grub-emu USB support'
+ 'sdl: For grub-emu SDL support')
fi
validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
- '95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
+ 'BE5C23209ACDDACEB20DB0A28C8189F1988C2166' # Daniel Kiper <dkiper@net-space.pl>
+ '95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
-source=("https://ftp.gnu.org/gnu/${pkgname%-libzfs}/${pkgname%-libzfs}-${pkgver}.tar.xz"{,.sig}
- "https://git.savannah.nongnu.org/cgit/grub-extras.git/snapshot/grub-extras-${_GRUB_EXTRAS_COMMIT}.tar.gz"
+source=("git+https://git.savannah.gnu.org/git/grub.git#tag=grub-${_pkgver}?signed"
+ "git+https://git.savannah.gnu.org/git/grub-extras.git#commit=${_GRUB_EXTRAS_COMMIT}"
+ "git+https://git.savannah.gnu.org/git/gnulib.git#commit=${_GNULIB_COMMIT}"
"https://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"{,.sig}
'0003-10_linux-detect-archlinux-initramfs.patch'
'0004-add-GRUB_COLOR_variables.patch'
- '0005-Allow_GRUB_to_mount_ext234_filesystems_that_have_the_encryption_feature.patch'
- '0006-tsc-Change-default-tsc-calibration-method-to-pmtimer-on-EFI-systems.patch'
- '0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch'
- '0008-Fix-packed-not-aligned-error-on-GCC-8.patch'
- '0009-xfs-Accept-filesystem-with-sparse-inodes.patch'
- '0010-relocation.patch'
'grub.default')
-sha256sums=('810b3798d316394f94096ec2797909dbf23c858e48f7b3830826b8daa06b7b0f'
+sha256sums=('SKIP'
+ 'SKIP'
'SKIP'
- '2844601914cea6b1231eca0104853a93c4d67a5209933a0766f1475953300646'
'04d652be1e28a6d464965c75c71ac84633085cd0960c2687466651c34c94bd89'
'SKIP'
- 'b41e4438319136b5e74e0abdfcb64ae115393e4e15207490272c425f54026dd3'
+ '171415ab075d1ac806f36c454feeb060f870416f24279b70104bba94bd6076d4'
'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
- '535422c510a050d41efe7720dbe54de29e04bdb8f86fd5aea5feb0b24f7abe46'
- 'c38f2b2caae33008b35a37d8293d8bf13bf6fd779a4504925da1837fd007aeb5'
- 'e43566c4fe3b1b87e677167323d4716b82ac0810410a9d8dc7fbf415c8db2b8a'
- 'e84b8de569c7e6b73263758c35cf95c6516fde85d4ed451991427864f6a4e5a8'
- 'fcd5a626d4af33665d041ce42df813f1f198d8230ea186481b155a5b676f3b87'
- '51562fa1016c54567dbf42a86c0cfc902372ab579bbee17879a81aff09b76b99'
- '74e5dd2090a153c10a7b9599b73bb09e70fddc6a019dd41641b0f10b9d773d82')
+ 'fd2e5f5453f3e44a2cb640c796b85cd70da8359c703f94cd531d457ede8c77fa')
+
+_backports=(
+)
_configure_options=(
FREETYPE="pkg-config freetype2"
@@ -109,7 +103,14 @@ _configure_options=(
)
prepare() {
- cd "${srcdir}/grub-${pkgver}/"
+ cd "${srcdir}/grub/"
+
+ echo "Apply backports..."
+ local _c
+ for _c in "${_backports[@]}"; do
+ git log --oneline -1 "${_c}"
+ git cherry-pick -n "${_c}"
+ done
echo "Patch to detect of Arch Linux initramfs images by grub-mkconfig..."
patch -Np1 -i "${srcdir}/0003-10_linux-detect-archlinux-initramfs.patch"
@@ -118,24 +119,6 @@ prepare() {
## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
patch -Np1 -i "${srcdir}/0004-add-GRUB_COLOR_variables.patch"
- echo "Patch to allow GRUB to mount ext2/3/4 filesystems that have the encryption feature..."
- patch -Np1 -i "${srcdir}/0005-Allow_GRUB_to_mount_ext234_filesystems_that_have_the_encryption_feature.patch"
-
- echo "Patch to change default tsc calibration method to pmtimer on EFI systems..."
- patch -Np1 -i "${srcdir}/0006-tsc-Change-default-tsc-calibration-method-to-pmtimer-on-EFI-systems.patch"
-
- echo "Patch to Support multiple early initrd images..."
- patch -Np1 -i "${srcdir}/0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch"
-
- echo "Patch to fix packed-not-aligned error on GCC 8..."
- patch -Np1 -i "${srcdir}/0008-Fix-packed-not-aligned-error-on-GCC-8.patch"
-
- echo "Patch xfs: Accept filesystem with sparse inodes..."
- patch -Np1 -i "${srcdir}/0009-xfs-Accept-filesystem-with-sparse-inodes.patch"
-
- echo "Patch x86-64: Treat R_X86_64_PLT32 as R_X86_64_PC32..."
- patch -Np1 -i "${srcdir}/0010-relocation.patch"
-
echo "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme..."
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
@@ -153,10 +136,12 @@ prepare() {
echo "Avoid problem with unifont during compile of grub..."
# http://savannah.gnu.org/bugs/?40330 and https://bugs.archlinux.org/task/37847
- zcat "${srcdir}/unifont-${_UNIFONT_VER}.bdf" > "unifont.bdf"
+ gzip -cd "${srcdir}/unifont-${_UNIFONT_VER}.bdf.gz" > "unifont.bdf"
- echo "Run autogen.sh..."
- ./autogen.sh
+ echo "Run bootstrap..."
+ ./bootstrap \
+ --gnulib-srcdir="${srcdir}/gnulib/" \
+ --no-git
}
_build_grub-common_and_bios() {
@@ -168,14 +153,14 @@ _build_grub-common_and_bios() {
fi
echo "Copy the source for building the bios part..."
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-bios"
- cd "${srcdir}/grub-${pkgver}-bios/"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-bios/"
+ cd "${srcdir}/grub-bios/"
echo "Add the grub-extra sources for bios build..."
- install -d "${srcdir}/grub-${pkgver}-bios/grub-extras"
- cp -r "${srcdir}/grub-extras-${_GRUB_EXTRAS_COMMIT}/915resolution" \
- "${srcdir}/grub-${pkgver}-bios/grub-extras/915resolution"
- export GRUB_CONTRIB="${srcdir}/grub-${pkgver}-bios/grub-extras/"
+ install -d "${srcdir}/grub-bios/grub-extras"
+ cp -r "${srcdir}/grub-extras/915resolution" \
+ "${srcdir}/grub-bios/grub-extras/915resolution"
+ export GRUB_CONTRIB="${srcdir}/grub-bios/grub-extras/"
echo "Unset all compiler FLAGS for bios build..."
unset CFLAGS
@@ -198,8 +183,8 @@ _build_grub-common_and_bios() {
_build_grub-efi() {
echo "Copy the source for building the ${_EFI_ARCH} efi part..."
- cp -r "${srcdir}/grub-${pkgver}" "${srcdir}/grub-${pkgver}-efi-${_EFI_ARCH}"
- cd "${srcdir}/grub-${pkgver}-efi-${_EFI_ARCH}/"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-efi-${_EFI_ARCH}/"
+ cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
echo "Unset all compiler FLAGS for ${_EFI_ARCH} efi build..."
unset CFLAGS
@@ -222,8 +207,8 @@ _build_grub-efi() {
_build_grub-emu() {
echo "Copy the source for building the emu part..."
- cp -r "${srcdir}/grub-${pkgver}/" "${srcdir}/grub-${pkgver}-emu/"
- cd "${srcdir}/grub-${pkgver}-emu/"
+ cp -r "${srcdir}/grub/" "${srcdir}/grub-emu/"
+ cd "${srcdir}/grub-emu/"
echo "Unset all compiler FLAGS for emu build..."
unset CFLAGS
@@ -246,7 +231,7 @@ _build_grub-emu() {
}
build() {
- cd "${srcdir}/grub-${pkgver}/"
+ cd "${srcdir}/grub/"
echo "Build grub bios stuff..."
_build_grub-common_and_bios
@@ -266,7 +251,7 @@ build() {
}
_package_grub-common_and_bios() {
- cd "${srcdir}/grub-${pkgver}-bios/"
+ cd "${srcdir}/grub-bios/"
echo "Run make install for bios build..."
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -281,7 +266,7 @@ _package_grub-common_and_bios() {
}
_package_grub-efi() {
- cd "${srcdir}/grub-${pkgver}-efi-${_EFI_ARCH}/"
+ cd "${srcdir}/grub-efi-${_EFI_ARCH}/"
echo "Run make install for ${_EFI_ARCH} efi build..."
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -293,7 +278,7 @@ _package_grub-efi() {
}
_package_grub-emu() {
- cd "${srcdir}/grub-${pkgver}-emu/"
+ cd "${srcdir}/grub-emu/"
echo "Run make install for emu build..."
make DESTDIR="${pkgdir}/" bashcompletiondir="/usr/share/bash-completion/completions" install
@@ -305,7 +290,7 @@ _package_grub-emu() {
}
package() {
- cd "${srcdir}/grub-${pkgver}/"
+ cd "${srcdir}/grub/"
echo "Package grub ${_EFI_ARCH} efi stuff..."
_package_grub-efi