summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bd8b4847129..7b308a5db63a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-# Maintainer : Christian Hesse <mail@eworm.de>
-# Maintainer : Ronald van Haren <ronald.archlinux.org>
+# Maintainer: Denton Liu <liu.denton@gmail.com>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
@@ -19,8 +20,9 @@ _UNIFONT_VER="11.0.02"
[[ "${CARCH}" == "x86_64" ]] && _EMU_ARCH="x86_64"
[[ "${CARCH}" == "i686" ]] && _EMU_ARCH="i386"
-pkgname='grub'
-pkgdesc='GNU GRand Unified Bootloader (2)'
+_basepkgname="grub"
+pkgname="${_basepkgname}-linux-default"
+pkgdesc='GNU GRand Unified Bootloader (2) with linux as the default kernel'
pkgver=2.02
pkgrel=8
epoch=2
@@ -29,16 +31,15 @@ arch=('x86_64')
license=('GPL3')
backup=('etc/default/grub'
'etc/grub.d/40_custom')
-install="${pkgname}.install"
+install="${_basepkgname}.install"
options=('!makeflags')
-conflicts=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-legacy')
-replaces=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
-provides=('grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
+conflicts=('grub' 'grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}" 'grub-legacy')
+provides=('grub' 'grub-common' 'grub-bios' 'grub-emu' "grub-efi-${_EFI_ARCH}")
makedepends=('git' 'rsync' 'xz' 'freetype2' 'ttf-dejavu' 'python' 'autogen'
'texinfo' 'help2man' 'gettext' 'device-mapper' 'fuse2')
-depends=('sh' 'xz' 'gettext' 'device-mapper')
+depends=('linux' 'sh' 'xz' 'gettext' 'device-mapper')
optdepends=('freetype2: For grub-mkfont usage'
'fuse2: For grub-mount usage'
'dosfstools: For grub-mkrescue FAT FS and EFI support'
@@ -56,9 +57,10 @@ fi
validpgpkeys=('E53D497F3FA42AD8C9B4D1E835A93B74E82E4209' # Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
'95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
-source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
+source=("https://ftp.gnu.org/gnu/${_basepkgname}/${_basepkgname}-${pkgver}.tar.xz"{,.sig}
"https://git.savannah.nongnu.org/cgit/grub-extras.git/snapshot/grub-extras-${_GRUB_EXTRAS_COMMIT}.tar.gz"
"https://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"{,.sig}
+ '0000-default-kernel.patch'
'0003-10_linux-detect-archlinux-initramfs.patch'
'0004-add-GRUB_COLOR_variables.patch'
'0005-Allow_GRUB_to_mount_ext234_filesystems_that_have_the_encryption_feature.patch'
@@ -74,6 +76,7 @@ sha256sums=('810b3798d316394f94096ec2797909dbf23c858e48f7b3830826b8daa06b7b0f'
'2844601914cea6b1231eca0104853a93c4d67a5209933a0766f1475953300646'
'a7ea9ca4f6dcb59377d978194835ede669457069256184f86d46ab5b863c56e6'
'SKIP'
+ '55e383e6693f47c0951806e76397d4da5f5a77c3b77f8b84479bf67b0bfb0017'
'b41e4438319136b5e74e0abdfcb64ae115393e4e15207490272c425f54026dd3'
'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
'535422c510a050d41efe7720dbe54de29e04bdb8f86fd5aea5feb0b24f7abe46'
@@ -110,6 +113,9 @@ _configure_options=(
prepare() {
cd "${srcdir}/grub-${pkgver}/"
+ echo "Patch to make GRUB use linux as the default kernel"
+ patch -Np1 -i "${srcdir}/0000-default-kernel.patch"
+
echo "Patch to detect of Arch Linux initramfs images by grub-mkconfig..."
patch -Np1 -i "${srcdir}/0003-10_linux-detect-archlinux-initramfs.patch"